Jump to content
Endless Gamers Community
Sign in to follow this  
Nightfire

TF2 failing to update

Recommended Posts

Nightfire    2

This is probably the wrong place to put this thread, but because there's really no other thread to put it into, and this is related to TF2, I've decided this is the most appropriate spot.

So right when the jungle inferno update rolled around, I came home to an update. Simple, right? Well, no. Of course not.gbs.thumb.PNG.220ddca8b7d00ed41f996f884ef2ee17.PNG

This just had to occur. So, I thought "There's an easy fix for this. I've dealt with it before." (which I actually have) and I decided to start doing the norm; verifying my game cache, changing download regions, etc.

Still, no yield. I tried restarting my PC 5 times; 2 of them being manual restarts and 3 being BSODs, namely PAGED_ERROR_IN_NONPAGED_AREA and SYSTEM_SERVICE_EXCEPTION as usual. If this sounds confusing to you, trust me, it is. I don't know what causes it, but I haven't been able to link it directly to steam at all.

Anyways, after that, the update still wouldn't start. Tried clicking play. Nothing. Tried RESETTING my download cache. Still nothing. Then I had the bright idea to hit up google. "That's how everyone fixes their busted PCs, right?", I thought. Of course I was wrong. I was desperate enough to open up CMD and try stopping a service called DiagTrack, or something along those lines even though I had no clue what I was even stopping. Access Denied. I then relaunched CMD in administrator, and it successfully stopped the process. You'd think doing that would even help me in the slightest bit, right?

Take a big guess.

 

Bottom line is I need help and I'm willing to do pretty much anything besides reinstalling steam and TF2. Those already took a week to install, and I'm not dealing with that on a weekend. And if you don't mind, don't make some stupid joke about how I need better internet or I need a better PC, because that won't help and you're just going to waste your time.

Oh, yeah, also, one more thing:MUNS.thumb.PNG.96c9aab6879202df0b226f810a5d1104.PNG

EDIT: Tried using steam beta to download and this happened. SNI.thumb.PNG.38a6d8c2c9805428154f5803ff20bfd3.PNG Now it's bricked.

Edited by Nightfire

Share this post


Link to post
Share on other sites
LiMaaa    775

Go into Steam Settings and under the Downloads tab, there is an option to select your download region. It might take some trial and error (which can be annoying since you have to restart steam every time you do this), but after trying a few different servers you should be able to fix the problem. Keep in mind it doesn't hurt to try servers in regions that are not in your country.

 

Vietnam usually works well.

You may need to delete localconfig.vdf in your steam folder (search for it) and restart steam then try.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×